вторник, 22 февраля 2011 г.

Solaris 10 Jumpstart Server

This installation was made from SF T2000 server for SF T1000 client


1.First preparations.
We must have or download new Solaris image or DVD disk for creating source directories for client installation.
Also we must have configured network on server which will be base install server for clients.
Now we can start, first of all we create two directories for our install and conf files and we share them through NFS. It's very simple.
# mkdir /export/install/5.10u3-sparc
# mkdir /export/jumpstart
# vi /etc/dfs/dfstab
share -F nfs -o ro,anon=0 /export/install/5.10u9-sparc
share -F nfs -o ro,anon=0 /export/jumpstart

Finally to share (and verify) these directories, use the following command:
# shareall

2.Installing Jumpstart Server
Assuming that we have DVD inserted into DVD Drive, we start to create core for jumpstart server
# cd /cdrom/cdrom0/s0/Solaris_10/Tools
# ./setup_install_server /export/install/5.10u3-sparc

This is a long process, that I suggest to you to be patient.
After compliting this job we start to create bootserver.
# cd /cdrom/cdrom0/s0/Solaris_10/Tools
# ./setup_install_server -b /export/install/5.10u3-sparc/sun4v

3. Jumpstart conf. files
As usual in Unix/Linux systems we may find sample files, and so we do.
# cp -r /cdrom/cdrom0/s0/Solaris_10/Misc/jumpstart_sample/* /export/jumpstart

/export/jumpstart/rules
This file is mandatory and helps to define some rules to specify what (type of) clients are allowed to use this install server and what to do before and after the installation. I created a single rule as follows:
network XX.XX.XX.0 && arch sparc - myT1000 -

which says that only SPARC systems in the XX.XX.XX.0 network are allowed to use this server and when they do, the settings in the myT1000 file should be used to specify how those systems should be configured.


/export/jumpstart/myT1000
This file specifies how a given system should be configured by allowing you to predefine what type of installation you want, which software packages you want (and do not want) and how to lay out your file systems etc.Here is the profile file that I used:

install_type initial_install
system_type server
partitioning explicit
filesys c0t0d0s0 15000 /
filesys c0t0d0s1 8000 swap
filesys c0t0d0s3 10240 /var
filesys c0t0d0s4 10240 /home
cluster SUNWXall add

/export/jumpstart/sysidcfg
This is an optional file that essentially allows you to specify extra settings for your installation. In summary, the more settings you specify here, the less questions you are asked during the network installation and the more automated the process becomes. Here is the sysidcfg file that I used:

system_locale=C
install_locale=C
timezone=Asia/Tashkent
terminal=vt100
timeserver=localhost
name_service=DNS { domain_name=XXX.XX name_server=XXX.XXX.XXX.XXX search=XXX.XX }
network_interface=bge0 {netmask=255.255.255.0 default_route=XXX.XXX.XXX.XXX protocol_ipv6=no}
security_policy=NONE

Once you have all of these files in place, you need to verify that they are syntactically correct. This is done using the check tool as follows:

# cd /export/jumpstart
# ./check
Validating rules...
Validating profile myT1000...
The custom JumpStart configuration is ok.

4. Telling the server about a client

Before you can commence an installation from a client, you need to tell the install server about that client. Since I was not using DHCP and already had a DNS server with a valid entry for my client, this stage was a little easier for me. Of course you also need to ensure that your server is running a TFTP Boot Server.
To tell the server about a client, you need to know the MAC address of the primary network adapter of the client and the intended hostname of the client. Once you know this, use the following command:

# cd /export/install/5.10u9-sparc/Solaris_10/Tools
# ./add_install_client -e 11:22:33:44:55:66 -s 192.168.0.240:/export/install/5.10u3-sparc -c 192.168.0.240:/export/jumpstart -p 192.168.0.240:/export/jumpstart T1000-spare sun4v

The name of my client was T1000-spare (it was a sun4v system) the IP of my server was 192.168.0.240. Clearly, you will need to use your own values for the parameters as well as the correct MAC address. The result of this command is some new files in the TFTP Boot area as well an a new entry in the /etc/ethers file.

5. Starting the Client Installation
This is actually the simplest part of the exercise and involves one command. However, you do need to ensure that the Network Management port of your client has been configured with a valid IP address. Anyway, to start the client installation, use the following command from the boot prompt of your client:

boot net - install

The system should then start installing the new version of Solaris. It will do things like request an IP address from the network, attempt to configure the network interfaces in the client and ultimately follow pretty much the same procedure as if you were installing from a CD or DVD. The more configuration files you provided on the server, the fewer questions you will be asked during the installation.
When the installation has completed, you will be dropped back to the (root) command prompt. You should now reboot the system after which you will be asked to provide a password for the root user. Upon completion of this task, you should finally be presented with the console login prompt and, you’re done!

четверг, 17 февраля 2011 г.

Task 3: Configure Static and Dynamic NAT on HQ

Step 1. Configure NAT.
Use the following requirements:

Allow all addresses for the 10.0.0.0/8 address space to be translated.
XYZ Corporation owns the 209.165.200.240/29 address space. The pool, XYZCORP, uses addresses .241 through .245 with a /29 mask.
The www.xyzcorp.com website at 10.0.1.2 is registered with the public DNS system at IP address 209.165.200.246.

First we must specify new access-list for using NAT:

HQ(config)#ip access-list standard NAT_LIST
HQ(config-std-nacl)#permit 10.0.0.0 0.255.255.255 
HQ(config-std-nacl)#exit

Second action is enabling dynamic NAT translation on HQ.For this action follow the requirements we must create NAT Pool:

HQ(config)#ip nat pool XYZCORP 209.165.200.241 209.165.200.245 net 255.255.255.248
HQ(config)#ip nat inside source list NAT_LIST pool XYZCORP overload

And last action is enabling static NAT:

HQ(config)#ip nat inside source static 10.0.1.2 209.165.200.246

Also we must activate NAT mode on all interfaces include each subinteface on HQ router.
For all interfaces exclude serial 0/1/0 NAT mode must be configured as inside, for example:

HQ(config)#interface serial 0/0/0.41
HQ(config-subif)#ip nat inside 

For serial 0/1/0 it must be:

HQ(config)#interface serial 0/1/0
HQ(config-subif)#ip nat outside

After completion your percentage must be 11%

четверг, 10 февраля 2011 г.

CCNA Skills Integration Challenge - Task 2

Task 2: Configure PPP with CHAP and PAP Authentication

Step 1. Configure the WAN link from HQ to ISP using PPP encapsulation and CHAP authentication.

The CHAP password is ciscochap.

We open console on HQ again and begin...

HQ>enable 
HQ#conf t
Enter configuration commands, one per line. End with CNTL/Z.
HQ(config)#interface serial 0/1/0
HQ(config-if)#ip address 209.165.201.1 255.255.255.252
HQ(config-if)#no shutdown 
%LINK-5-CHANGED: Interface Serial0/1/0, changed state to up
HQ(config-if)#encapsulation ppp 
HQ(config-if)#ppp authentication chap 
HQ(config-if)#exit
HQ(config)#username ISP password ciscochap 
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/1/0, changed state to up
do ping 209.165.201.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 209.165.201.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 6/8/14 ms
HQ(config)#do copy r s
Destination filename [startup-config]? 
Building configuration...
[OK]

Step 2. Configure the WAN link from HQ to NewB using PPP encapsulation and PAP authentication.
You need to connect a cable to the correct interfaces. HQ is the DCE side of the link. You choose the clock rate. The PAP password is ciscopap.
First of all we have to choose the cable for connecting. This job is easy enough. In the bottom of the PT we choose cable with clock label.
First we connect it to DCE side of the link (HQ Serial 0/0/1), and the second connection will be serial 0/0/0 on NewB router.
And now start to configure PPP using PAP authentification on HQ.

HQ(config)#interface serial 0/0/1
HQ(config-if)#ip address 10.255.255.253 255.255.255.252
HQ(config-if)#no shutdown 
%LINK-5-CHANGED: Interface Serial0/0/1, changed state to up
HQ(config-if)#encapsulation ppp
HQ(config-if)#ppp authentication pap 
HQ(config-if)#ppp pap sent-username HQ password ciscopap 
HQ(config-if)#exit
HQ(config)#username NewB password ciscopap
HQ(config)#interface serial 0/0/1
HQ(config-if)#clock rate 64000
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/1, changed state to up
HQ(config-if)#do copy r s
Destination filename [startup-config]? 
Building configuration...
[OK]
HQ(config-if)#

And last thing that we need to do is adding new username and password on NewB for successful connection between routers.

NewB#conf t
Enter configuration commands, one per line. End with CNTL/Z.
NewB(config)#username HQ password ciscopap
NewB(config)#do copy r s
Destination filename [startup-config]? 
Building configuration...
[OK]

After veryfing pinging between HQ and ISP, HQ and NewB, you may start Task 3. On your Acrivity progress you will see 8% Completion.

CCNA Skills Integration Challenge - Task 1

This series of articles is oriented for students, studying in Cisco Web Academies all over the world.I hope that this material will help to you in your preparation to CISCO CCNA exams.
I successfully passed it on December 13, 2010 with 936 mark.

Task 1: Configure Frame Relay in a Hub-and-Spoke Topology.
Step 1.Configure the Frame Relay core.

Use the addressing tables and the following requirements.
HQ is the hub router. B1, B2, and B3 are the spokes.
- HQ uses a point-to-point subinterface for each of the Branch routers.
- B3 must be manually configured to use IETF encapsulation.
- The LMI type must be manually configured as q933a for HQ, B1, and B2. B3 uses ANSI.

First of all we must configure HQ as a hub router. Entering console:

Router>enable 
Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname HQ
HQ(config)#interface serial 0/0/0
HQ(config-if)#encapsulation frame-relay 
HQ(config-if)#no shutdown 
%LINK-5-CHANGED: Interface Serial0/0/0, changed state to up
HQ(config-if)#frame-relay lmi-type q933a 
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up
HQ(config-if)#exit
HQ(config)#interface serial 0/0/0.41 point-to-point
%LINK-5-CHANGED: Interface Serial0/0/0.41, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0.41, changed state to up
HQ(config-subif)#ip address 10.255.255.1 255.255.255.252
HQ(config-subif)#frame-relay interface-dlci 41
HQ(config-subif)#exit
HQ(config)#interface serial 0/0/0.42 point-to-point 
%LINK-5-CHANGED: Interface Serial0/0/0.42, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0.42, changed state to up
ipad
HQ(config-subif)#ip address 10.255.255.5 255.255.255.252
HQ(config-subif)#frame-relay interface-dlci 42
HQ(config-subif)#exit
HQ(config)#interface serial 0/0/0.43 point-to-point 
%LINK-5-CHANGED: Interface Serial0/0/0.43, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0.43, changed state to up
HQ(config-subif)#ip address 10.255.255.9 255.255.255.252
HQ(config-subif)#frame-relay interface-dlci 43
HQ(config-subif)#exit
HQ#copy r s
Destination filename [startup-config]? 
Building configuration...
[OK]


Second action in this task is configuring other routers as spokes. Configuring steps:

Router>enable 
Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname B1
B1(config)#interface serial 0/0/0
B1(config-if)#encapsulation frame-relay
B1(config-if)#frame-relay lmi-type q933a 
B1(config-if)#ip address 10.255.255.2 255.255.255.252
B1(config-if)#no shutdown 
%LINK-5-CHANGED: Interface Serial0/0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up
B1#
%SYS-5-CONFIG_I: Configured from console by console
ping 10.255.255.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.255.255.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 5/8/10 ms
B1#copy r s
Destination filename [startup-config]? 
Building configuration...
[OK]


And we have to repeat this step for another two spoke routers, with changing several parameters as IP address and lmi-types if needed.

Router>enable 
Router#conf t
Router(config)#hostname B2
B2(config)#interface serial 0/0/0
B2(config-if)#encapsulation frame-relay
B2(config-if)#frame-relay lmi-type q933a 
B2(config-if)#ip address 10.255.255.6 255.255.255.252
B2(config-if)#no shutdown 
%LINK-5-CHANGED: Interface Serial0/0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up
B2#
%SYS-5-CONFIG_I: Configured from console by console
ping 10.255.255.5
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.255.255.5, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 5/8/10 ms
B1#copy r s
Destination filename [startup-config]? 
Building configuration...
[OK]


And last third router B3:

Router>enable
Router#configure t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname B3
B3(config)#interface serial 0/0/0
B3(config-if)#encapsulation frame-relay ietf
B3(config-if)#frame-relay lmi-type ansi
B3(config-if)#ip address 10.255.255.10 255.255.255.252
B3(config-if)#no shutdown
%LINK-5-CHANGED: Interface Serial0/0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up
do ping 10.255.255.9
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.255.255.9, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 8/9/10 ms
B3(config-if)#
B3#
B3#copy r s
Destination filename [startup-config]?
Building configuration...
[OK]


That's all for step one. Step 2 Congifuring the LAN interface on HQ router.

HQ>enable
HQ#conf t
Enter configuration commands, one per line. End with CNTL/Z.
HQ(config)#interface fa0/0
HQ(config-if)#ip address 10.0.1.1 255.255.255.0
HQ(config-if)#no shutdown
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
HQ(config-if)#do copy r s
Destination filename [startup-config]?
Building configuration...
[OK]

Step 3 is a veryfing all configs with simple ping command, HQ must ping each Routers.

четверг, 3 февраля 2011 г.

Changing default WiFi drivers Ubuntu

First question.Why I start this topic? When I installed Ubuntu on my laptop, in this case it was "Acer Aspire 4530", it worked pretty. But I founded one issue in my WiFi configuration, it shows me that my speed is 1 Mbit/s. That will not do!!!
I wanted to change this injustice, first thing what I've done was downloading appropriate drivers for WinXP, for my laptop from official site.
Than I installed "ndiswrapper" application from the repository.

sudo apt-get install ndiswrapper

Next, opened the program and show it on the "Inf" file, which we downloaded previously.
Than we must turn off our existed drivers, with modifying blacklist file in modprobe configuration.
For me it was:

:~$ cat /etc/modprobe.d/blacklist-ath_pci.conf
# For some Atheros 5K RF MACs, the madwifi driver loads buts fails to
# correctly initialize the hardware, leaving it in a state from
# which ath5k cannot recover. To prevent this condition, stop
# madwifi from loading by default. Use Jockey to select one driver
# or the other. (Ubuntu: #315056, #323830)
blacklist ath_pci
blacklist ath5k


I added last srting, which shows that we blocked using existed driver.
Than we should restart our laptop, with init 6 command or another method.
Out OS booted you can see, that now your speed is 54Mbit/s
Good luck!